We can't start Excel Mobile Viewer because it may be turned off. Please contact your help desk.

​You feel like part of the digital age as you flip open your mobile device and get ready to check that spreadsheet on the move. And then up pops this dreary monochrome message and you suddenly feel like you have travelled back in time and are in a 1950's film noir. Your part in the mobile revolution has been put on hold until you sort out the Excel Mobile Viewer which is the responsibility of the "help desk" which is, of course, you. Probably you didn't even realise there was a special viewer for mobile devices - after all, what's wrong with the regular Excel web viewer?

ExcelMobileViewer.png


Now the first thing we come to is an area of confusion about who, as in which group within Microsoft, is responsible for rendering Excel to web browsers. There are two candidates; the first is WAC, or OWA (Office Web Apps) to give it the consumer-friendly name, which used to be part of SharePoint but since the 2013 version has become a separate product that you deploy to its own server. The second is Excel Web Services. At this point you may be thinking "surely you wouldn't end up with two product groups at Microsoft duplicating functionality". Yes, well...

So the question is: which of those two mechanisms is rendering my Excel workbooks? It all depends on whether you have OWA configured in your farm and if so, what the WOPI bindings should be (WOPI is the "hackronym" given to the Office API). To find out you simply need to look at the URL. If the page name is WopiFrame.aspx you're using OWA, and if it's xlviewer.aspx then you're using Excel Services, and that's also the one that has the Excel Mobile Viewer that is mysteriously turned off.

Again, you would think this would get "turned on" by default but it turns out that in some cases you have to do this yourself. It is a site collection scoped feature, but you won't find it in the site collection features list in site settings because it is hidden. You need to go to PowerShell to enable it. The feature ID is E995E28B-9BA8-4668-9933-CF5C146D7A9F and I expect you will want to commit that to memory as another of those many SharePoint things you just have to know.

Alternatively, come back to this page when you see this error and copy the following bit of PowerShell script, seasoning to taste:

Enable-SPFeature -Identity E995E28B-9BA8-4668-9933-CF5C146D7A9F -Url "http://mysite.com/" -force